aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/qt.mk
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-11-25 15:29:38 +0800
committerfanquake <fanquake@gmail.com>2021-11-25 15:33:10 +0800
commit4cc998ce9d1445cae3c8a60443980221196ab508 (patch)
treef75332f05c187267324570e29dc01d1594181a55 /depends/packages/qt.mk
parent064c729a964ab8d9df5edda18c8b4a9e075789e6 (diff)
parent8196b0a2bc63c35769eca213cba4a5844a737b90 (diff)
downloadbitcoin-4cc998ce9d1445cae3c8a60443980221196ab508.tar.xz
Merge bitcoin/bitcoin#23580: build: patch qt to explicitly define previously implicit header include
8196b0a2bc63c35769eca213cba4a5844a737b90 build: patch qt to explicitly define previously implicit header include (Kittywhiskers Van Gogh) Pull request description: ### Description macOS Monterey has refactored some includes such that implicitly defined headers were no longer exposed and that in turns breaks building Qt on macOS 12. First observed when building on an M1 Pro. See "Additional Reading" for more information. ### Additional Reading * https://github.com/microsoft/vcpkg/issues/21055 (resolved by https://github.com/microsoft/vcpkg/commit/c32ccbb34caacea28ba2d2b3df232ee36359c9f6) * ["Add missing macOS header file that was indirectly included before"](https://code.qt.io/cgit/qt/qtbase.git/commit/src/plugins/platforms/cocoa?id=dece6f5840463ae2ddf927d65eb1b3680e34a547) on https://code.qt.io/ ACKs for top commit: hebasto: ACK 8196b0a2bc63c35769eca213cba4a5844a737b90, verified that the patch is applied cleanly: fanquake: ACK 8196b0a2bc63c35769eca213cba4a5844a737b90 Tree-SHA512: efe6d93edd2e2f68f33a1c353d353c8e7b5aa680733561caa6eb092fd0f68153f8ed1649a61048ef873f6be8041b9ca8e6919d80b947181b6fe4152464e2d383
Diffstat (limited to 'depends/packages/qt.mk')
-rw-r--r--depends/packages/qt.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/depends/packages/qt.mk b/depends/packages/qt.mk
index 12e0494ad4..a5472ef624 100644
--- a/depends/packages/qt.mk
+++ b/depends/packages/qt.mk
@@ -13,6 +13,7 @@ $(package)_patches += support_new_android_ndks.patch fix_android_jni_static.patc
$(package)_patches+= no_sdk_version_check.patch
$(package)_patches+= fix_lib_paths.patch fix_android_pch.patch
$(package)_patches+= qtbase-moc-ignore-gcc-macro.patch fix_limits_header.patch
+$(package)_patches+= fix_montery_include.patch
$(package)_qttranslations_file_name=qttranslations-$($(package)_suffix)
$(package)_qttranslations_sha256_hash=577b0668a777eb2b451c61e8d026d79285371597ce9df06b6dee6c814164b7c3
@@ -232,6 +233,7 @@ define $(package)_preprocess_cmds
patch -p1 -i $($(package)_patch_dir)/fix_lib_paths.patch && \
patch -p1 -i $($(package)_patch_dir)/qtbase-moc-ignore-gcc-macro.patch && \
patch -p1 -i $($(package)_patch_dir)/fix_limits_header.patch && \
+ patch -p1 -i $($(package)_patch_dir)/fix_montery_include.patch && \
mkdir -p qtbase/mkspecs/macx-clang-linux &&\
cp -f qtbase/mkspecs/macx-clang/qplatformdefs.h qtbase/mkspecs/macx-clang-linux/ &&\
cp -f $($(package)_patch_dir)/mac-qmake.conf qtbase/mkspecs/macx-clang-linux/qmake.conf && \