aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/qt.mk
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-07-16 14:59:03 +0300
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-07-18 12:10:01 +0300
commitcac7890386e773d9c268febd38b4311e6d35e03f (patch)
treec12c7ddd31f87605a9c0e9ab8756054cc99005e1 /depends/packages/qt.mk
parente8f85e0e86e92e583b8984455b7bf9d0a777578a (diff)
downloadbitcoin-cac7890386e773d9c268febd38b4311e6d35e03f.tar.xz
build: Add support for Android NDK r22+
Diffstat (limited to 'depends/packages/qt.mk')
-rw-r--r--depends/packages/qt.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/depends/packages/qt.mk b/depends/packages/qt.mk
index 0c3ef8c82f..9004b064d6 100644
--- a/depends/packages/qt.mk
+++ b/depends/packages/qt.mk
@@ -9,7 +9,7 @@ $(package)_qt_libs=corelib network widgets gui plugins testlib
$(package)_linguist_tools = lrelease lupdate lconvert
$(package)_patches = qt.pro qttools_src.pro
$(package)_patches += fix_qt_pkgconfig.patch mac-qmake.conf fix_no_printer.patch no-xlib.patch
-$(package)_patches+= fix_android_qmake_conf.patch fix_android_jni_static.patch dont_hardcode_pwd.patch
+$(package)_patches += support_new_android_ndks.patch fix_android_jni_static.patch dont_hardcode_pwd.patch
$(package)_patches+= no_sdk_version_check.patch
$(package)_patches+= fix_lib_paths.patch fix_android_pch.patch
$(package)_patches+= qtbase-moc-ignore-gcc-macro.patch fix_limits_header.patch
@@ -224,7 +224,7 @@ define $(package)_preprocess_cmds
patch -p1 -i $($(package)_patch_dir)/dont_hardcode_pwd.patch && \
patch -p1 -i $($(package)_patch_dir)/fix_qt_pkgconfig.patch && \
patch -p1 -i $($(package)_patch_dir)/fix_no_printer.patch && \
- patch -p1 -i $($(package)_patch_dir)/fix_android_qmake_conf.patch && \
+ patch -p1 -i $($(package)_patch_dir)/support_new_android_ndks.patch && \
patch -p1 -i $($(package)_patch_dir)/fix_android_jni_static.patch && \
patch -p1 -i $($(package)_patch_dir)/fix_android_pch.patch && \
patch -p1 -i $($(package)_patch_dir)/no-xlib.patch && \