aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/qt.mk
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2019-07-17 16:21:30 -0400
committerCarl Dong <contact@carldong.me>2019-07-17 17:04:39 -0400
commit9a01ab04e1125b37618266d7fd1c3a6e3bb7e3f8 (patch)
tree083dc482745ec5920e8d58c86bbb237b5f2f4ac7 /depends/packages/qt.mk
parent1ec30b8fbe4a162d6e2e6a9711d83f1bafd9b645 (diff)
downloadbitcoin-9a01ab04e1125b37618266d7fd1c3a6e3bb7e3f8.tar.xz
depends: qt: Explicitly stop using Xlib/libX11
Previously, in 683b7d7a3fc1b9240333faf3d04497aa61583016 and 0e752637a26cf75187864a466db9a92540a2d3c8, we accidentally broke QT's ability to pick up Xlib thru the config.gui.tests.xlib configuration test, which also means that config.gui.libraries.xcb_xlib wasn't run. This resulted in a QT build that was implicitly -no-xcb-lib and -no-feature-xlib. This is actually a desired behaviour, as it means less required shared objects for our final bitcoin-qt binary. Specifically, it eliminated the libX11-xcb.so.1 and libX11.so.6 requirements. In this commit, we explicitly build without Xlib. We should continue to track upstream ticket https://bugreports.qt.io/browse/QTBUG-61452 which talks about adding a -no-xlib (non-hidden) flag instead of the -no-feature-xlib (hidden) flag.
Diffstat (limited to 'depends/packages/qt.mk')
-rw-r--r--depends/packages/qt.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/depends/packages/qt.mk b/depends/packages/qt.mk
index 7b70087544..d0beb8888c 100644
--- a/depends/packages/qt.mk
+++ b/depends/packages/qt.mk
@@ -98,6 +98,8 @@ endif
$(package)_config_opts_linux = -qt-xkbcommon-x11
$(package)_config_opts_linux += -qt-xcb
+$(package)_config_opts_linux += -no-xcb-xlib
+$(package)_config_opts_linux += -no-feature-xlib
$(package)_config_opts_linux += -system-freetype
$(package)_config_opts_linux += -no-feature-sessionmanager
$(package)_config_opts_linux += -fontconfig