aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/qt.mk
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-09-05 22:55:54 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-09-08 14:42:46 -0400
commit21f139b4a622f07679f1d1c30ad32e2b40a2617e (patch)
treefd8e753338e1e752d349102494f6fce22affddb4 /depends/packages/qt.mk
parent6ee78938ee6fda4fd80ece1eb5d736c79045eddd (diff)
downloadbitcoin-21f139b4a622f07679f1d1c30ad32e2b40a2617e.tar.xz
qt: fix tablet crash. closes #4854.
This backports the relevant parts of: https://codereview.qt-project.org/#/c/82689/
Diffstat (limited to 'depends/packages/qt.mk')
-rw-r--r--depends/packages/qt.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/depends/packages/qt.mk b/depends/packages/qt.mk
index cce7d6e6ef..e719e2e506 100644
--- a/depends/packages/qt.mk
+++ b/depends/packages/qt.mk
@@ -7,7 +7,7 @@ $(package)_dependencies=openssl
$(package)_linux_dependencies=freetype fontconfig dbus libxcb libX11 xproto libXext
$(package)_build_subdir=qtbase
$(package)_qt_libs=corelib network widgets gui plugins testlib
-$(package)_patches=mac-qmake.conf fix-xcb-include-order.patch
+$(package)_patches=mac-qmake.conf fix-xcb-include-order.patch qt5-tablet-osx.patch
define $(package)_set_vars
$(package)_config_opts = -release -opensource -confirm-license
@@ -52,7 +52,8 @@ define $(package)_preprocess_cmds
cp -f qtbase/mkspecs/macx-clang/Info.plist.app qtbase/mkspecs/macx-clang-linux/ &&\
cp -f qtbase/mkspecs/macx-clang/qplatformdefs.h qtbase/mkspecs/macx-clang-linux/ &&\
cp -f $($(package)_patch_dir)/mac-qmake.conf qtbase/mkspecs/macx-clang-linux/qmake.conf && \
- patch -p1 < $($(package)_patch_dir)/fix-xcb-include-order.patch
+ patch -p1 < $($(package)_patch_dir)/fix-xcb-include-order.patch && \
+ patch -p1 < $($(package)_patch_dir)/qt5-tablet-osx.patch
endef
define $(package)_config_cmds