aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/packages.mk
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-08-28 23:21:18 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-11-19 22:49:41 -0500
commit5f93ec202810c1bc082f181fbfe6af4438b395fe (patch)
treef5535da2a48ecc838d6c3190905bc6b6aa43988b /depends/packages/packages.mk
parent4302fa67b12794648abb40a9e9f18230041691b4 (diff)
downloadbitcoin-5f93ec202810c1bc082f181fbfe6af4438b395fe.tar.xz
depends: Add a package for qt4.6. Linux uses it by default.
We're not ready to switch to a static qt5 for Linux yet due to missing plugin support. This adds a recipe for building a shared qt4 that we build and link against, but don't distribute. make USE_LINUX_STATIC_QT5=1 can be used to build static qt5 as before.
Diffstat (limited to 'depends/packages/packages.mk')
-rw-r--r--depends/packages/packages.mk13
1 files changed, 11 insertions, 2 deletions
diff --git a/depends/packages/packages.mk b/depends/packages/packages.mk
index 0e1fbeffaa..305d21cb2d 100644
--- a/depends/packages/packages.mk
+++ b/depends/packages/packages.mk
@@ -2,8 +2,17 @@ packages:=boost openssl gmp
native_packages := native_ccache native_comparisontool
qt_native_packages = native_protobuf
-qt_packages = qt qrencode protobuf
-qt_linux_packages=expat dbus libxcb xcb_proto libXau xproto freetype fontconfig libX11 xextproto libXext xtrans
+qt_packages = qrencode protobuf
+
+qt46_linux_packages = qt46 expat dbus libxcb xcb_proto libXau xproto freetype libX11 xextproto libXext xtrans libICE libSM
+qt5_linux_packages= qt expat dbus libxcb xcb_proto libXau xproto freetype fontconfig libX11 xextproto libXext xtrans
+
+qt_darwin_packages=qt
+qt_mingw32_packages=qt
+
+qt_linux_$(USE_LINUX_STATIC_QT5):=$(qt5_linux_packages)
+qt_linux_:=$(qt46_linux_packages)
+qt_linux_packages:=$(qt_linux_$(USE_LINUX_STATIC_QT5))
wallet_packages=bdb