aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/native_libdmg-hfsplus.mk
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-07-23 01:31:30 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-08-08 15:10:46 -0400
commit1dec09b341f61836147d87656aea7f7be02aab6d (patch)
treebda4c72a414edf94b91537eb2fe9c6da5c6942b8 /depends/packages/native_libdmg-hfsplus.mk
parent36065cc529bb9be5655fcaaad2746edb7b6f4ddb (diff)
downloadbitcoin-1dec09b341f61836147d87656aea7f7be02aab6d.tar.xz
depends: add shared dependency builder
See the README's in depends for documentation
Diffstat (limited to 'depends/packages/native_libdmg-hfsplus.mk')
-rw-r--r--depends/packages/native_libdmg-hfsplus.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/depends/packages/native_libdmg-hfsplus.mk b/depends/packages/native_libdmg-hfsplus.mk
new file mode 100644
index 0000000000..a4ffb6046c
--- /dev/null
+++ b/depends/packages/native_libdmg-hfsplus.mk
@@ -0,0 +1,22 @@
+package=native_libdmg-hfsplus
+$(package)_version=0.1
+$(package)_download_path=https://github.com/theuni/libdmg-hfsplus/archive
+$(package)_file_name=libdmg-hfsplus-v$($(package)_version).tar.gz
+$(package)_sha256_hash=6569a02eb31c2827080d7d59001869ea14484c281efab0ae7f2b86af5c3120b3
+$(package)_build_subdir=build
+
+define $(package)_preprocess_cmds
+ mkdir build
+endef
+
+define $(package)_config_cmds
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=$(build_prefix)/bin ..
+endef
+
+define $(package)_build_cmds
+ $(MAKE) -C dmg
+endef
+
+define $(package)_stage_cmds
+ $(MAKE) DESTDIR=$($(package)_staging_dir) -C dmg install
+endef