aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/native_ds_store.mk
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-11-07 16:58:21 +0800
committerfanquake <fanquake@gmail.com>2020-11-11 08:01:02 +0800
commit7087440894a9daa7de806c5aa42d83ad60759c65 (patch)
treef2bf72563eda31360d121137f00a092c970d776c /depends/packages/native_ds_store.mk
parentfa8dd34e918cd80db215df8937aaf6bb1552fcd9 (diff)
downloadbitcoin-7087440894a9daa7de806c5aa42d83ad60759c65.tar.xz
depends: native_ds_store 1.3.0
native_ds_store now takes advantage of Pythons ability to decode binary plists (since 3.4), so we can drop its biplist dependency. The call to biplist.Data() in custom_dsstore doesn't seem to do anything, and from what I can tell can just be removed.
Diffstat (limited to 'depends/packages/native_ds_store.mk')
-rw-r--r--depends/packages/native_ds_store.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/depends/packages/native_ds_store.mk b/depends/packages/native_ds_store.mk
index f99b689ecd..44108925a4 100644
--- a/depends/packages/native_ds_store.mk
+++ b/depends/packages/native_ds_store.mk
@@ -1,10 +1,9 @@
package=native_ds_store
-$(package)_version=1.1.2
+$(package)_version=1.3.0
$(package)_download_path=https://github.com/al45tair/ds_store/archive/
$(package)_file_name=v$($(package)_version).tar.gz
-$(package)_sha256_hash=3b3ecb7bf0a5157f5b6010bc3af7c141fb0ad3527084e63336220d22744bc20c
+$(package)_sha256_hash=76b3280cd4e19e5179defa23fb594a9dd32643b0c80d774bd3108361d94fb46d
$(package)_install_libdir=$(build_prefix)/lib/python3/dist-packages
-$(package)_dependencies=native_biplist
define $(package)_build_cmds
python3 setup.py build