aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/native_ds_store.mk
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2019-03-14 15:08:54 -0400
committerMarcoFalke <falke.marco@gmail.com>2019-03-14 15:47:00 -0400
commitfa0f92af9ae35c0e6c8068241ff7a34b06d1a262 (patch)
treef8ea9f5e2c2c2c1dec666bd9abee9f3405158766 /depends/packages/native_ds_store.mk
parent887f57eb727643eb1f37999a022f3817aaab6d00 (diff)
downloadbitcoin-fa0f92af9ae35c0e6c8068241ff7a34b06d1a262.tar.xz
build: depends: Switch to python3
Diffstat (limited to 'depends/packages/native_ds_store.mk')
-rw-r--r--depends/packages/native_ds_store.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/depends/packages/native_ds_store.mk b/depends/packages/native_ds_store.mk
index 116fa25d38..f99b689ecd 100644
--- a/depends/packages/native_ds_store.mk
+++ b/depends/packages/native_ds_store.mk
@@ -3,14 +3,14 @@ $(package)_version=1.1.2
$(package)_download_path=https://github.com/al45tair/ds_store/archive/
$(package)_file_name=v$($(package)_version).tar.gz
$(package)_sha256_hash=3b3ecb7bf0a5157f5b6010bc3af7c141fb0ad3527084e63336220d22744bc20c
-$(package)_install_libdir=$(build_prefix)/lib/python/dist-packages
+$(package)_install_libdir=$(build_prefix)/lib/python3/dist-packages
$(package)_dependencies=native_biplist
define $(package)_build_cmds
- python setup.py build
+ python3 setup.py build
endef
define $(package)_stage_cmds
mkdir -p $($(package)_install_libdir) && \
- python setup.py install --root=$($(package)_staging_dir) --prefix=$(build_prefix) --install-lib=$($(package)_install_libdir)
+ python3 setup.py install --root=$($(package)_staging_dir) --prefix=$(build_prefix) --install-lib=$($(package)_install_libdir)
endef