aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/native_biplist.mk
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2016-07-19 15:41:36 -0400
committerWladimir J. van der Laan <laanwj@gmail.com>2016-07-20 09:11:41 +0200
commit1fe7f404078121ad370ec955aa23befa322549bb (patch)
tree87f3888fd7254e1c8060789b5c7a2a2918cf6863 /depends/packages/native_biplist.mk
parentd6bb231a9fa902b5d7a719f8cbcba34c6a7a57cf (diff)
downloadbitcoin-1fe7f404078121ad370ec955aa23befa322549bb.tar.xz
build: fix non-deterministic biplist
The non-deterministic ordering produced by biplist ends up in the .DS_Store file that is included in the OSX dmg. Github-Pull: #8373 Rebased-From: 3b3ce25df6cc84cd1e75a7ec20fc7da8d2ef76e0
Diffstat (limited to 'depends/packages/native_biplist.mk')
-rw-r--r--depends/packages/native_biplist.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/depends/packages/native_biplist.mk b/depends/packages/native_biplist.mk
index eb8672d556..3c6e8900f6 100644
--- a/depends/packages/native_biplist.mk
+++ b/depends/packages/native_biplist.mk
@@ -4,6 +4,11 @@ $(package)_download_path=https://pypi.python.org/packages/source/b/biplist
$(package)_file_name=biplist-$($(package)_version).tar.gz
$(package)_sha256_hash=b57cadfd26e4754efdf89e9e37de87885f9b5c847b2615688ca04adfaf6ca604
$(package)_install_libdir=$(build_prefix)/lib/python/dist-packages
+$(package)_patches=sorted_list.patch
+
+define $(package)_preprocess_cmds
+ patch -p1 < $($(package)_patch_dir)/sorted_list.patch
+endef
define $(package)_build_cmds
python setup.py build