aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/libxcb.mk
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2019-09-24 11:01:19 +0800
committerfanquake <fanquake@gmail.com>2019-10-11 11:54:39 -0400
commitbcff8e21b1bb360c3cf1e1d2e1a2a54ec7581720 (patch)
treecb51f7bd2b97c3b1c406c4a7afeabb88b7d4983e /depends/packages/libxcb.mk
parent82615876109845a7fa0d12941d13c37f34f8d286 (diff)
downloadbitcoin-bcff8e21b1bb360c3cf1e1d2e1a2a54ec7581720.tar.xz
build: only pass --disable-dependency-tracking to packages that understand it
By blanket passing --disable-dependency-tracking to all depends packages we end up with some warnings like: configure: WARNING: unrecognized options: --disable-dependency-tracking So instead, only pass it to packages that understand it. Related to https://github.com/bitcoin/bitcoin/issues/16354.
Diffstat (limited to 'depends/packages/libxcb.mk')
-rw-r--r--depends/packages/libxcb.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/depends/packages/libxcb.mk b/depends/packages/libxcb.mk
index 49d3e3d15b..3c63d4a30e 100644
--- a/depends/packages/libxcb.mk
+++ b/depends/packages/libxcb.mk
@@ -6,7 +6,7 @@ $(package)_sha256_hash=98d9ab05b636dd088603b64229dd1ab2d2cc02ab807892e107d674f9c
$(package)_dependencies=xcb_proto libXau
define $(package)_set_vars
-$(package)_config_opts=--disable-static --disable-build-docs --without-doxygen --without-launchd
+$(package)_config_opts=--disable-static --disable-build-docs --without-doxygen --without-launchd --disable-dependency-tracking
# Because we pass -qt-xcb to Qt, it will compile in a set of xcb helper libraries and extensions,
# so we skip building all of the extensions here.
# More info is available from: https://doc.qt.io/qt-5.9/linux-requirements.html