aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/libxcb.mk
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-03-07 23:03:38 +0200
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-03-07 23:03:38 +0200
commit5129b36573cb07d8bcbac493506c46e26d7239eb (patch)
tree111e9a03ddbafbbb72252656a51a4e6174a03006 /depends/packages/libxcb.mk
parent8c21562180d25389b450dc90e761ba3fc266a9da (diff)
downloadbitcoin-5129b36573cb07d8bcbac493506c46e26d7239eb.tar.xz
build: Clean remnants of QTBUG-34748 fix
A fix for QTBUG-34748 was introduced in #5915 (v0.11.0, Qt 5.2.1). QTBUG-34748 was fixed in version 5.3.0. The separated patch file, provided by #5915, was dropped in #12971 while bumping Qt to 5.9.4 (5.9.6). But libxcb.mk remained unchanged. This change reverts #5915 for libxcb.mk.
Diffstat (limited to 'depends/packages/libxcb.mk')
-rw-r--r--depends/packages/libxcb.mk7
1 files changed, 1 insertions, 6 deletions
diff --git a/depends/packages/libxcb.mk b/depends/packages/libxcb.mk
index 2204b38195..ba08b7e951 100644
--- a/depends/packages/libxcb.mk
+++ b/depends/packages/libxcb.mk
@@ -27,13 +27,8 @@ define $(package)_preprocess_cmds
sed "s/pthread-stubs//" -i configure
endef
-# Don't install xcb headers to the default path in order to work around a qt
-# build issue: https://bugreports.qt.io/browse/QTBUG-34748
-# When using qt's internal libxcb, it may end up finding the real headers in
-# depends staging. Use a non-default path to avoid that.
-
define $(package)_config_cmds
- $($(package)_autoconf) --includedir=$(host_prefix)/include/xcb-shared
+ $($(package)_autoconf)
endef
define $(package)_build_cmds