aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/libXau.mk
diff options
context:
space:
mode:
authorCarl Dong <accounts@carldong.me>2019-04-18 13:49:11 -0400
committerCarl Dong <accounts@carldong.me>2019-05-28 11:02:42 -0400
commit683b7d7a3fc1b9240333faf3d04497aa61583016 (patch)
tree76237925723b5850a00f9703121a7883f84384d6 /depends/packages/libXau.mk
parent14209286df4a91a0e6738268339ba667d868a11f (diff)
downloadbitcoin-683b7d7a3fc1b9240333faf3d04497aa61583016.tar.xz
depends: Purge libtool archives
We use pkg-config where we can, which generally replaces libtool at a higher level and does not have the same downsides as libtool. These archives sit in our depends tree with no purpose and pollute the final bitcoin build with massive overlinking.
Diffstat (limited to 'depends/packages/libXau.mk')
-rw-r--r--depends/packages/libXau.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/depends/packages/libXau.mk b/depends/packages/libXau.mk
index ce42140689..0e4a60ad25 100644
--- a/depends/packages/libXau.mk
+++ b/depends/packages/libXau.mk
@@ -25,3 +25,7 @@ endef
define $(package)_stage_cmds
$(MAKE) DESTDIR=$($(package)_staging_dir) install
endef
+
+define $(package)_postprocess_cmds
+ rm lib/*.la
+endef