aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/libXau.mk
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2019-09-24 11:01:19 +0800
committerfanquake <fanquake@gmail.com>2019-10-11 11:54:39 -0400
commitbcff8e21b1bb360c3cf1e1d2e1a2a54ec7581720 (patch)
treecb51f7bd2b97c3b1c406c4a7afeabb88b7d4983e /depends/packages/libXau.mk
parent82615876109845a7fa0d12941d13c37f34f8d286 (diff)
downloadbitcoin-bcff8e21b1bb360c3cf1e1d2e1a2a54ec7581720.tar.xz
build: only pass --disable-dependency-tracking to packages that understand it
By blanket passing --disable-dependency-tracking to all depends packages we end up with some warnings like: configure: WARNING: unrecognized options: --disable-dependency-tracking So instead, only pass it to packages that understand it. Related to https://github.com/bitcoin/bitcoin/issues/16354.
Diffstat (limited to 'depends/packages/libXau.mk')
-rw-r--r--depends/packages/libXau.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/depends/packages/libXau.mk b/depends/packages/libXau.mk
index 058416f793..0b83f46834 100644
--- a/depends/packages/libXau.mk
+++ b/depends/packages/libXau.mk
@@ -8,7 +8,7 @@ $(package)_dependencies=xproto
# When updating this package, check the default value of
# --disable-xthreads. It is currently enabled.
define $(package)_set_vars
- $(package)_config_opts=--disable-shared --disable-lint-library --without-lint
+ $(package)_config_opts=--disable-shared --disable-lint-library --without-lint --disable-dependency-tracking
$(package)_config_opts_linux=--with-pic
endef