aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/libX11.mk
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2019-07-17 16:21:50 -0400
committerCarl Dong <contact@carldong.me>2019-07-17 17:04:40 -0400
commitaa53cb7a2f04a59a4722c662e67b7a6ec04e32b5 (patch)
treec665441297afff48bc807db497235c40a3db562a /depends/packages/libX11.mk
parent9a01ab04e1125b37618266d7fd1c3a6e3bb7e3f8 (diff)
downloadbitcoin-aa53cb7a2f04a59a4722c662e67b7a6ec04e32b5.tar.xz
depends: libX11: Make package headers-only
We're no longer building QT with libX11/XLib, however, libX11/XLib headers are still required for parts of QT. In this commit we add a minimal configure.ac for libX11/XLib that is headers-only. This change allows us to remove all of libX11/XLib's dependencies.
Diffstat (limited to 'depends/packages/libX11.mk')
-rw-r--r--depends/packages/libX11.mk22
1 files changed, 5 insertions, 17 deletions
diff --git a/depends/packages/libX11.mk b/depends/packages/libX11.mk
index f46bd9219e..abf21963e7 100644
--- a/depends/packages/libX11.mk
+++ b/depends/packages/libX11.mk
@@ -3,30 +3,18 @@ $(package)_version=1.6.2
$(package)_download_path=https://xorg.freedesktop.org/releases/individual/lib/
$(package)_file_name=$(package)-$($(package)_version).tar.bz2
$(package)_sha256_hash=2aa027e837231d2eeea90f3a4afe19948a6eb4c8b2bec0241eba7dbc8106bd16
-$(package)_dependencies=libxcb xtrans xextproto xproto
-
-define $(package)_set_vars
- # See libXext for --disable-malloc0returnsnull rationale.
- $(package)_config_opts=--disable-xkb --disable-static --disable-malloc0returnsnull
- $(package)_config_opts_linux=--with-pic
-endef
+$(package)_patches=configure.ac
define $(package)_preprocess_cmds
- cp -f $(BASEDIR)/config.guess $(BASEDIR)/config.sub .
+ cp -f $(BASEDIR)/config.guess $(BASEDIR)/config.sub . && \
+ cp -f $($(package)_patch_dir)/configure.ac .
endef
define $(package)_config_cmds
+ autoreconf --install --force --verbose && \
$($(package)_autoconf)
endef
-define $(package)_build_cmds
- $(MAKE)
-endef
-
define $(package)_stage_cmds
- $(MAKE) DESTDIR=$($(package)_staging_dir) install
-endef
-
-define $(package)_postprocess_cmds
- rm lib/*.la
+ $(MAKE) -C include DESTDIR=$($(package)_staging_dir) install-x11includeHEADERS
endef