aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/libSM.mk
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-08-28 23:21:18 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-11-19 22:49:41 -0500
commit5f93ec202810c1bc082f181fbfe6af4438b395fe (patch)
treef5535da2a48ecc838d6c3190905bc6b6aa43988b /depends/packages/libSM.mk
parent4302fa67b12794648abb40a9e9f18230041691b4 (diff)
downloadbitcoin-5f93ec202810c1bc082f181fbfe6af4438b395fe.tar.xz
depends: Add a package for qt4.6. Linux uses it by default.
We're not ready to switch to a static qt5 for Linux yet due to missing plugin support. This adds a recipe for building a shared qt4 that we build and link against, but don't distribute. make USE_LINUX_STATIC_QT5=1 can be used to build static qt5 as before.
Diffstat (limited to 'depends/packages/libSM.mk')
-rw-r--r--depends/packages/libSM.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/depends/packages/libSM.mk b/depends/packages/libSM.mk
new file mode 100644
index 0000000000..0f9307ca76
--- /dev/null
+++ b/depends/packages/libSM.mk
@@ -0,0 +1,23 @@
+package=libSM
+$(package)_version=1.2.2
+$(package)_download_path=http://xorg.freedesktop.org/releases/individual/lib/
+$(package)_file_name=$(package)-$($(package)_version).tar.bz2
+$(package)_sha256_hash=0baca8c9f5d934450a70896c4ad38d06475521255ca63b717a6510fdb6e287bd
+$(package)_dependencies=xtrans xproto libICE
+
+define $(package)_set_vars
+ $(package)_config_opts=--without-libuuid --without-xsltproc --disable-docs --disable-static
+ $(package)_config_opts_linux=--with-pic
+endef
+
+define $(package)_config_cmds
+ $($(package)_autoconf)
+endef
+
+define $(package)_build_cmds
+ $(MAKE)
+endef
+
+define $(package)_stage_cmds
+ $(MAKE) DESTDIR=$($(package)_staging_dir) install
+endef