aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/expat.mk
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2019-06-05 16:34:12 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2019-06-05 16:37:56 +0200
commit03858b23fe1d17e681eb18d24602b276020295a0 (patch)
tree22d5a6a0ac5391a8869d11444eb54bb6e7ff4329 /depends/packages/expat.mk
parent03e2786f05c88f978d9fc830668b8f8cd8b5551f (diff)
parent8541cbea29f96b756cfb5ec1894d818b4c870924 (diff)
downloadbitcoin-03858b23fe1d17e681eb18d24602b276020295a0.tar.xz
Merge #15844: depends: Purge libtool archives
8541cbea2 depends: libX*: --disable-malloc0returnsnull in conf (Carl Dong) 0e752637a depends: libXext: Bump to 1.3.3 to fix _XEatDataWords (Carl Dong) 683b7d7a3 depends: Purge libtool archives (Carl Dong) 14209286d depends: Build secondary deps statically. (Carl Dong) Pull request description: ``` We use pkg-config where we can, which generally replaces libtool at a higher level and does not have the same downsides as libtool. These archives sit in our depends tree with no purpose and pollute the final bitcoin build with massive overlinking. ``` See [here](https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Handling_Libtool_Archives) for an explanation of the various problems libtool archives can cause. Unrelated in every way except in spirit: `-D__LIBTOOL_IS_A_FOOL__`!! ----- This PR is based on #16041, and therefore should be merged after #16041. ACKs for commit 8541cb: Tree-SHA512: 76030cf32361f0b1cfe14e3827a0cbec99994e7da00a56194ca40cf6cf7d87f78552f49d03d41ce9cf9b642992b90d993578ed1f0ad6bae15cd3f1c88dfaa4b0
Diffstat (limited to 'depends/packages/expat.mk')
-rw-r--r--depends/packages/expat.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/depends/packages/expat.mk b/depends/packages/expat.mk
index 8d06882cdb..b811f84a38 100644
--- a/depends/packages/expat.mk
+++ b/depends/packages/expat.mk
@@ -5,7 +5,8 @@ $(package)_file_name=$(package)-$($(package)_version).tar.bz2
$(package)_sha256_hash=17b43c2716d521369f82fc2dc70f359860e90fa440bea65b3b85f0b246ea81f2
define $(package)_set_vars
-$(package)_config_opts=--disable-static --without-docbook
+ $(package)_config_opts=--disable-shared --without-docbook
+ $(package)_config_opts_linux=--with-pic
endef
define $(package)_config_cmds
@@ -19,3 +20,7 @@ endef
define $(package)_stage_cmds
$(MAKE) DESTDIR=$($(package)_staging_dir) install
endef
+
+define $(package)_postprocess_cmds
+ rm lib/*.la
+endef