aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/boost.mk
diff options
context:
space:
mode:
authorPeter Bushnell <bushsolo@gmail.com>2020-01-16 13:23:02 +0000
committerPeter Bushnell <bushsolo@gmail.com>2020-01-16 13:23:02 +0000
commit22c5a986e95d2bd14273465ca0e15fbe3772252d (patch)
treef4974a229b37ef287ce5f1c0b284f7ebf441aff5 /depends/packages/boost.mk
parentac61ec9da6793f00b29ba11f784b9b1c3ae662e9 (diff)
downloadbitcoin-22c5a986e95d2bd14273465ca0e15fbe3772252d.tar.xz
depends: Consistent use of package variable
All other mk files use the package variable consistently except for the two instances here, which have always been here, since depends was introduced in 0.10.
Diffstat (limited to 'depends/packages/boost.mk')
-rw-r--r--depends/packages/boost.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/depends/packages/boost.mk b/depends/packages/boost.mk
index d360bb5ba6..cd0e70fb1c 100644
--- a/depends/packages/boost.mk
+++ b/depends/packages/boost.mk
@@ -29,11 +29,11 @@ $(package)_cxxflags_android=-fPIC
endef
define $(package)_preprocess_cmds
- echo "using $(boost_toolset_$(host_os)) : : $($(package)_cxx) : <cxxflags>\"$($(package)_cxxflags) $($(package)_cppflags)\" <linkflags>\"$($(package)_ldflags)\" <archiver>\"$(boost_archiver_$(host_os))\" <striper>\"$(host_STRIP)\" <ranlib>\"$(host_RANLIB)\" <rc>\"$(host_WINDRES)\" : ;" > user-config.jam
+ echo "using $($(package)_toolset_$(host_os)) : : $($(package)_cxx) : <cxxflags>\"$($(package)_cxxflags) $($(package)_cppflags)\" <linkflags>\"$($(package)_ldflags)\" <archiver>\"$($(package)_archiver_$(host_os))\" <striper>\"$(host_STRIP)\" <ranlib>\"$(host_RANLIB)\" <rc>\"$(host_WINDRES)\" : ;" > user-config.jam
endef
define $(package)_config_cmds
- ./bootstrap.sh --without-icu --with-libraries=$(boost_config_libraries)
+ ./bootstrap.sh --without-icu --with-libraries=$($(package)_config_libraries)
endef
define $(package)_build_cmds