aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/bdb.mk
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2016-01-07 08:55:56 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2016-01-07 08:56:03 +0100
commit41f1a3e99bfac07fd4d719575fa93016a31d9551 (patch)
tree3c0f10eaf55656dcf38442ea1b57f79306c9f914 /depends/packages/bdb.mk
parent605c17844ea32b6d237db6d83871164dc7d59dab (diff)
parent3968922b9623af9da9959adc49a779d6837e1f0c (diff)
Merge pull request #7302
3968922 c++11: fix libbdb build against libc++ in c++11 mode (Cory Fields) 57d2f62 c++11: CAccountingEntry must be defined before use in a list (Cory Fields) 89f71c6 c++11: don't throw from the reverselock destructor (Cory Fields) 76ac35f c++11: detect and correct for boost builds with an incompatible abi (Cory Fields)
Diffstat (limited to 'depends/packages/bdb.mk')
-rw-r--r--depends/packages/bdb.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/depends/packages/bdb.mk b/depends/packages/bdb.mk
index 68841afdb8..e2f85ad4fc 100644
--- a/depends/packages/bdb.mk
+++ b/depends/packages/bdb.mk
@@ -12,7 +12,8 @@ $(package)_config_opts_linux=--with-pic
endef
define $(package)_preprocess_cmds
- sed -i.old 's/__atomic_compare_exchange/__atomic_compare_exchange_db/' dbinc/atomic.h
+ sed -i.old 's/__atomic_compare_exchange/__atomic_compare_exchange_db/' dbinc/atomic.h && \
+ sed -i.old 's/atomic_init/atomic_init_db/' dbinc/atomic.h mp/mp_region.c mp/mp_mvcc.c mp/mp_fget.c mutex/mut_method.c mutex/mut_tas.c
endef
define $(package)_config_cmds