aboutsummaryrefslogtreecommitdiff
path: root/depends/hosts
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2020-09-30 19:20:41 -0400
committerCarl Dong <contact@carldong.me>2021-01-07 14:02:39 -0500
commit77b1ef89a07bf7a493ce4abaccbbff793cbde9be (patch)
tree20c1f53b111f4c8167f30ccc6448cc2fb9150393 /depends/hosts
parent300733921863c176535806c40afdc813b99e7459 (diff)
downloadbitcoin-77b1ef89a07bf7a493ce4abaccbbff793cbde9be.tar.xz
depends: Remove -fuse-ld line
clang warns when a command line option is unused, and some of our tests use Werror, so unfortunately we cannot use this flag to pin our linker for now. Leaving this commit in for future reference, as it would be great if there's more granularity to Werror and we can be explicit about what linker we want to use.
Diffstat (limited to 'depends/hosts')
-rw-r--r--depends/hosts/darwin.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/depends/hosts/darwin.mk b/depends/hosts/darwin.mk
index 83da049618..4a70d55405 100644
--- a/depends/hosts/darwin.mk
+++ b/depends/hosts/darwin.mk
@@ -64,7 +64,6 @@ darwin_CC=env -u C_INCLUDE_PATH -u CPLUS_INCLUDE_PATH \
-u LIBRARY_PATH \
clang --target=$(host) -mmacosx-version-min=$(OSX_MIN_VERSION) \
-B$(build_prefix)/bin -mlinker-version=$(LD64_VERSION) \
- -fuse-ld=$(build_prefix)/bin/x86_64-apple-darwin16-ld \
--sysroot=$(OSX_SDK) \
-Xclang -internal-externc-isystem$(clang_resource_dir)/include \
-Xclang -internal-externc-isystem$(OSX_SDK)/usr/include
@@ -73,7 +72,6 @@ darwin_CXX=env -u C_INCLUDE_PATH -u CPLUS_INCLUDE_PATH \
-u LIBRARY_PATH \
clang++ --target=$(host) -mmacosx-version-min=$(OSX_MIN_VERSION) \
-B$(build_prefix)/bin -mlinker-version=$(LD64_VERSION) \
- -fuse-ld=$(build_prefix)/bin/x86_64-apple-darwin16-ld \
--sysroot=$(OSX_SDK) \
-stdlib=libc++ -nostdinc++ \
-Xclang -cxx-isystem$(OSX_SDK)/usr/include/c++/v1 \