aboutsummaryrefslogtreecommitdiff
path: root/depends/hosts
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-03-17 12:06:29 +0800
committerfanquake <fanquake@gmail.com>2021-03-30 14:54:08 +0800
commit765e0be5347e9d85cee03255204d94119e4cbf38 (patch)
tree3651c9087b924bd13755f38f6659df62994b51dd /depends/hosts
parent3ececa76b70cbc5b0eaba3a0ddf72f9bd681d906 (diff)
downloadbitcoin-765e0be5347e9d85cee03255204d94119e4cbf38.tar.xz
build: split native_cctools
Diffstat (limited to 'depends/hosts')
-rw-r--r--depends/hosts/darwin.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/depends/hosts/darwin.mk b/depends/hosts/darwin.mk
index 646e97837a..dd71697f0f 100644
--- a/depends/hosts/darwin.mk
+++ b/depends/hosts/darwin.mk
@@ -12,14 +12,13 @@ ifeq ($(strip $(FORCE_USE_SYSTEM_CLANG)),)
# FORCE_USE_SYSTEM_CLANG is empty, so we use our depends-managed, pinned clang
# from llvm.org
-# The native_cctools package is what provides clang when FORCE_USE_SYSTEM_CLANG
-# is empty
+# Clang is a dependency of native_cctools when FORCE_USE_SYSTEM_CLANG is empty
darwin_native_toolchain=native_cctools
clang_prog=$(build_prefix)/bin/clang
clangxx_prog=$(clang_prog)++
-clang_resource_dir=$(build_prefix)/lib/clang/$(native_cctools_clang_version)
+clang_resource_dir=$(build_prefix)/lib/clang/$(native_clang_version)
else
# FORCE_USE_SYSTEM_CLANG is non-empty, so we use the clang from the user's
# system