aboutsummaryrefslogtreecommitdiff
path: root/contrib/spendfrom/setup.py
diff options
context:
space:
mode:
authorGavin Andresen <gavinandresen@gmail.com>2013-01-04 20:05:56 -0500
committerGavin Andresen <gavinandresen@gmail.com>2013-01-24 20:04:18 -0500
commitdba91a9a6783057d7f308eeabb0ef4a6772c9562 (patch)
treee3a8401593fa1d845f48f33fa53e0f7943b89a39 /contrib/spendfrom/setup.py
parentea9788517bfa3e53e192c5af9e64e73625f9db74 (diff)
downloadbitcoin-dba91a9a6783057d7f308eeabb0ef4a6772c9562.tar.xz
spendfrom.py sends coins from a particular address or addresses
Should be both useful and also a pretty good demonstration of using the raw transactions API.
Diffstat (limited to 'contrib/spendfrom/setup.py')
-rw-r--r--contrib/spendfrom/setup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/contrib/spendfrom/setup.py b/contrib/spendfrom/setup.py
new file mode 100644
index 0000000000..01b9768a5b
--- /dev/null
+++ b/contrib/spendfrom/setup.py
@@ -0,0 +1,9 @@
+from distutils.core import setup
+setup(name='btcspendfrom',
+ version='1.0',
+ description='Command-line utility for bitcoin "coin control"',
+ author='Gavin Andresen',
+ author_email='gavin@bitcoinfoundation.org',
+ requires=['jsonrpc'],
+ scripts=['spendfrom.py'],
+ )