aboutsummaryrefslogtreecommitdiff
path: root/contrib/guix/manifest.scm
diff options
context:
space:
mode:
authormerge-script <fanquake@gmail.com>2024-06-26 15:21:44 +0100
committermerge-script <fanquake@gmail.com>2024-06-26 15:21:44 +0100
commit0c57a798b50bf03a0b69f632c691932d608254ef (patch)
tree13c472bda1502c9ad3729064e249a00f390fc778 /contrib/guix/manifest.scm
parent3f0ee7655b5cced47780507aa8e1654bcc8c16e5 (diff)
parentb5fc6d46a3854c18f6e8dfc89540d24ef778caa2 (diff)
Merge bitcoin/bitcoin#29987: guix: build with glibc 2.31
b5fc6d46a3854c18f6e8dfc89540d24ef778caa2 guix: use glibc 2.31 (fanquake) Pull request description: Set minimum required glibc to 2.31. The glibc 2.31 branch is still maintained: https://sourceware.org/git/?p=glibc.git;a=shortlog;h=refs/heads/release/2.31/master. Remove the stack-protector check from test-security-check, as the test no-longer fails, and given the control we have of the end, the actual security-check test seems sufficient (this might also be applied to some of the other checks). Drops runtime support for Ubuntu Bionic 18.04 and RHEL-8 from the release binaries. ACKs for top commit: TheCharlatan: ACK b5fc6d46a3854c18f6e8dfc89540d24ef778caa2 Tree-SHA512: ba7e727240fa0ebebfb8b749024c71cbfdec37c33b39627866d78f9318ccdc687fd5103a63ee0e98cf809d9954dde56b1b305691c33d1de275ed0519f716c921
Diffstat (limited to 'contrib/guix/manifest.scm')
-rw-r--r--contrib/guix/manifest.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/contrib/guix/manifest.scm b/contrib/guix/manifest.scm
index 53569d7f7d..44fbfa1c0b 100644
--- a/contrib/guix/manifest.scm
+++ b/contrib/guix/manifest.scm
@@ -98,7 +98,7 @@ chain for " target " development."))
#:key
(base-gcc-for-libc linux-base-gcc)
(base-kernel-headers base-linux-kernel-headers)
- (base-libc glibc-2.27)
+ (base-libc glibc-2.31)
(base-gcc linux-base-gcc))
"Convenience wrapper around MAKE-CROSS-TOOLCHAIN with default values
desirable for building Bitcoin Core release binaries."
@@ -440,24 +440,21 @@ inspecting signatures in Mach-O binaries.")
(("-rpath=") "-rpath-link="))
#t))))))))
-(define-public glibc-2.27
+(define-public glibc-2.31
+ (let ((commit "8e30f03744837a85e33d84ccd34ed3abe30d37c3"))
(package
- (inherit glibc-2.31)
- (version "2.27")
+ (inherit glibc) ;; 2.35
+ (version "2.31")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://sourceware.org/git/glibc.git")
- (commit "73886db6218e613bd6d4edf529f11e008a6c2fa6")))
- (file-name (git-file-name "glibc" "73886db6218e613bd6d4edf529f11e008a6c2fa6"))
+ (commit commit)))
+ (file-name (git-file-name "glibc" commit))
(sha256
(base32
- "0azpb9cvnbv25zg8019rqz48h8i2257ngyjg566dlnp74ivrs9vq"))
- (patches (search-our-patches "glibc-2.27-riscv64-Use-__has_include-to-include-asm-syscalls.h.patch"
- "glibc-2.27-fcommon.patch"
- "glibc-2.27-guix-prefix.patch"
- "glibc-2.27-no-librt.patch"
- "glibc-2.27-powerpc-ldbrx.patch"))))
+ "1zi0s9yy5zkisw823vivn7zlj8w6g9p3mm7lmlqiixcxdkz4dbn6"))
+ (patches (search-our-patches "glibc-guix-prefix.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments glibc)
((#:configure-flags flags)
@@ -473,12 +470,13 @@ inspecting signatures in Mach-O binaries.")
(lambda* (#:key outputs #:allow-other-keys)
;; Install the rpc data base file under `$out/etc/rpc'.
;; Otherwise build will fail with "Permission denied."
+ ;; Can be removed when we are building 2.32 or later.
(let ((out (assoc-ref outputs "out")))
(substitute* "sunrpc/Makefile"
(("^\\$\\(inst_sysconfdir\\)/rpc(.*)$" _ suffix)
(string-append out "/etc/rpc" suffix "\n"))
(("^install-others =.*$")
- (string-append "install-others = " out "/etc/rpc\n"))))))))))))
+ (string-append "install-others = " out "/etc/rpc\n")))))))))))))
(packages->manifest
(append