aboutsummaryrefslogtreecommitdiff
path: root/contrib/debian/rules
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2018-07-31 11:55:56 -0400
committerMarcoFalke <falke.marco@gmail.com>2018-07-31 11:56:09 -0400
commit77168f766f15c6621fb2af0dfcf2dd12b971172c (patch)
treeafa7b27ff287518b44ea24c646776610eb46fef9 /contrib/debian/rules
parent8ce55df70d31002a18fa1377119ec46a295b8846 (diff)
parentfa0e1e2f630e6ca6cdfca64d8d92a7f0f85baa4d (diff)
Merge #13809: contrib: Remove debian and rpm subfolder
fa0e1e2f63 contrib: Remove debian and rpm subfolders (MarcoFalke) Pull request description: The folders are now located here: * https://github.com/bitcoin-core/packaging/tree/master/debian * https://github.com/bitcoin-core/packaging/tree/master/rpm Note that I kept the copyright file, so that it can be updated for our purposes in the commit that adds new files. Tree-SHA512: 4c919e8e04cdcc56f2c4c16e83c68d5ec74b7e4438ca54222a37f85cf604b77880393d1a0004f16f270ab04ee00b2060129c5c2e0b34815679940f1c3b5754f3
Diffstat (limited to 'contrib/debian/rules')
-rwxr-xr-xcontrib/debian/rules23
1 files changed, 0 insertions, 23 deletions
diff --git a/contrib/debian/rules b/contrib/debian/rules
deleted file mode 100755
index 6885e38521..0000000000
--- a/contrib/debian/rules
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/usr/bin/make -f
-# -*- mode: makefile; coding: utf-8 -*-
-
-#DEB_MAKE_CHECK_TARGET = test_bitcoin
-#build/bitcoind::
-# $(if $(filter nocheck,$(DEB_BUILD_OPTIONS)),,src/test_bitcoin)
-
-%:
- dh --with bash-completion $@
-
-override_dh_auto_clean:
- if [ -f Makefile ]; then $(MAKE) distclean; fi
- rm -rf Makefile.in aclocal.m4 configure src/Makefile.in src/bitcoin-config.h.in src/build-aux src/qt/Makefile.in src/qt/test/Makefile.in src/test/Makefile.in
-
-QT=$(shell dpkg-vendor --derives-from Ubuntu && echo qt4 || echo qt5)
-
-# Yea, autogen should be run on the source archive, but I like doing git archive
-override_dh_auto_configure:
- ./autogen.sh
- ./configure --with-gui=$(QT)
-
-override_dh_auto_test:
- make check