aboutsummaryrefslogtreecommitdiff
path: root/contrib/debian/rules
diff options
context:
space:
mode:
authorctp-tsteenholdt <tsteenholdt@cascadetechnologypartners.com>2018-04-20 08:31:58 -0200
committerctp-tsteenholdt <tsteenholdt@cascadetechnologypartners.com>2018-04-20 08:31:58 -0200
commit9085532d35207c4a7690812ae82e476cf518d451 (patch)
tree39efd8754b58b3b8f328366252a50c5c729af230 /contrib/debian/rules
parent615f7c288414a89cd1dec1d67e0f84abe2fb4c6d (diff)
downloadbitcoin-9085532d35207c4a7690812ae82e476cf518d451.tar.xz
Sync contrib/debian from Matt Corallo's PPA
Diffstat (limited to 'contrib/debian/rules')
-rwxr-xr-xcontrib/debian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/contrib/debian/rules b/contrib/debian/rules
index 6885e38521..84c5edd4a4 100755
--- a/contrib/debian/rules
+++ b/contrib/debian/rules
@@ -13,6 +13,13 @@ override_dh_auto_clean:
rm -rf Makefile.in aclocal.m4 configure src/Makefile.in src/bitcoin-config.h.in src/build-aux src/qt/Makefile.in src/qt/test/Makefile.in src/test/Makefile.in
QT=$(shell dpkg-vendor --derives-from Ubuntu && echo qt4 || echo qt5)
+# qt4 is very broken on arm
+ifeq ($(findstring arm,$(shell uname -m)),arm)
+ QT=qt5
+endif
+ifeq ($(findstring aarch64,$(shell uname -m)),aarch64)
+ QT=qt5
+endif
# Yea, autogen should be run on the source archive, but I like doing git archive
override_dh_auto_configure:
@@ -20,4 +27,8 @@ override_dh_auto_configure:
./configure --with-gui=$(QT)
override_dh_auto_test:
+ifeq ($(QT), qt4)
+ xvfb-run -n 99 -l make check
+else
make check
+endif