aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-02-07 17:07:16 +0000
committerfanquake <fanquake@gmail.com>2023-02-08 16:10:34 +0000
commitb03a98291bc950d33d8e00e6fa578a9e3f8a1852 (patch)
tree94db424a4354b6ee26af5d361a35bec58dcde986 /configure.ac
parent07a23b494688d359b761d9ff11aff2be866a44ad (diff)
build: set boost cppflags with --enable-fuzz
Even though all other targets are disabled, we still need Boost CPPFLAGS (use_boost) to compile. This currently works everywhere, except on arm macOS (where the include path is pretty non-standard), because generally, the Boost include path is generic, i.e `/usr/include`.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2bbcfc0ffe..2b73cba6fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1451,7 +1451,7 @@ if test "$use_natpmp" != "no"; then
CPPFLAGS="$TEMP_CPPFLAGS"
fi
-if test "$build_bitcoin_wallet$build_bitcoin_cli$build_bitcoin_tx$build_bitcoin_util$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench" = "nononononononono"; then
+if test "$build_bitcoin_wallet$build_bitcoin_cli$build_bitcoin_tx$build_bitcoin_util$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench$enable_fuzz_binary" = "nonononononononono"; then
use_boost=no
else
use_boost=yes