aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwillcl-ark <will@256k1.dev>2023-05-22 10:46:36 +0100
committerfanquake <fanquake@gmail.com>2023-05-29 17:14:00 +0100
commit9dc58484928693a42e4163d8eaef3f8b47f1d3d8 (patch)
tree9573b2e78f8ea145064de71d27d499a3a303dcbd /configure.ac
parent725c3dc2dd1402d631e05ef461fe2abbac9a008f (diff)
build: disable boost multi index safe mode
Disable boost multi index safe mode by default when configuring with --enable-debug. This option can cause transactions to take a long time to be accepted into the mempool under certain conditions; iterator destruction takes O(n) time vs O(1) as they are stored in a singly linked list. See 27586 for more information. Re-enable it on the CI builds which previously had it enabled. Re-enable it on the msan fuzz target so that we have fuzz tasks testing with it enabeld and disabled in this repo. Github-Pull: #27724 Rebased-From: 59c89447499bd9d6202269879555b8bc37373aa2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c6dc5a6875..518f99e309 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1482,10 +1482,6 @@ if test "$use_boost" = "yes"; then
AX_CHECK_PREPROC_FLAG([-DBOOST_NO_CXX98_FUNCTION_BASE], [BOOST_CPPFLAGS="$BOOST_CPPFLAGS -DBOOST_NO_CXX98_FUNCTION_BASE"], [], [$CXXFLAG_WERROR],
[AC_LANG_PROGRAM([[#include <boost/config.hpp>]])])
- if test "$enable_debug" = "yes" || test "$enable_fuzz" = "yes"; then
- BOOST_CPPFLAGS="$BOOST_CPPFLAGS -DBOOST_MULTI_INDEX_ENABLE_SAFE_MODE"
- fi
-
if test "$suppress_external_warnings" != "no"; then
BOOST_CPPFLAGS=SUPPRESS_WARNINGS($BOOST_CPPFLAGS)
fi