aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2023-11-03 16:46:07 +0000
committerfanquake <fanquake@gmail.com>2023-11-09 17:14:22 +0000
commit3c61c60b90db1b6a77b3804784430fcd57b447b6 (patch)
treeaa13e5d1025e381474e1faa80816f3470f97734d /configure.ac
parent45257601da4cf38f081d9af2c18cd0be7174bcef (diff)
build: Add an old hack to remove bind_at_load from libtool.
Similar to a98356fee8a44d7d1cb37f22c876fff8f244365e.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7f235a9270..5d26f49e8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1969,6 +1969,17 @@ case ${OS} in
;;
esac
+dnl An old hack similar to a98356fee to remove hard-coded
+dnl bind_at_load flag from libtool
+case $host in
+ *darwin*)
+ AC_MSG_RESULT([Removing -Wl,bind_at_load from libtool.])
+ sed < libtool > libtool-2 '/bind_at_load/d'
+ mv libtool-2 libtool
+ chmod 755 libtool
+ ;;
+esac
+
echo
echo "Options used to compile and link:"
echo " external signer = $use_external_signer"