aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-05-07 19:25:31 +0300
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2021-07-27 14:53:24 +0300
commite4c8bb62e4a6873c45f42d0d2a24927cb241a0ea (patch)
treef6bfb6c2aee9a2c527e4207f720f6f372ecaf936 /configure.ac
parent741749a6159eb68dd8a3c5ef0d1701337931e6df (diff)
downloadbitcoin-e4c8bb62e4a6873c45f42d0d2a24927cb241a0ea.tar.xz
build: Fix undefined reference to __mulodi4
When compiling with clang on 32-bit systems the __mulodi4 symbol is defined in compiler-rt only.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2bc404250d..0a5456acff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1773,6 +1773,10 @@ if test x$build_bitcoin_wallet$build_bitcoin_cli$build_bitcoin_tx$build_bitcoin_
AC_MSG_ERROR([No targets! Please specify at least one of: --with-utils --with-libs --with-daemon --with-gui --enable-bench or --enable-tests])
fi
+if test x$enable_fuzz_binary = xyes; then
+ CHECK_RUNTIME_LIB
+fi
+
AM_CONDITIONAL([TARGET_DARWIN], [test x$TARGET_OS = xdarwin])
AM_CONDITIONAL([BUILD_DARWIN], [test x$BUILD_OS = xdarwin])
AM_CONDITIONAL([TARGET_LINUX], [test x$TARGET_OS = xlinux])