aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-12-07 15:33:21 +0800
committerfanquake <fanquake@gmail.com>2020-12-07 15:33:37 +0800
commitd0ca394596cf37c699b24c1ebab3bb5a80bdb748 (patch)
tree7d918ae2771cb9e73dc9dcccb8e9a9466df6e169 /configure.ac
parentcef2efafcecc4d3d60421955bbd4c4fcebbcb86d (diff)
parented1bbcefeaafef460b6e5609de85e13c12e0d2a4 (diff)
downloadbitcoin-d0ca394596cf37c699b24c1ebab3bb5a80bdb748.tar.xz
Merge #20476: contrib: Add test for ELF symbol-check
ed1bbcefeaafef460b6e5609de85e13c12e0d2a4 contrib: add MACHO tests to symbol-check tests (fanquake) 5bab08df175db3a4283596515e498fc5a4d0dab9 contrib: Add test for ELF symbol-check (Wladimir J. van der Laan) Pull request description: Check both failure cases: - Use a glibc symbol from a version that is too new - Use a symbol from a library that is not in the allowlist And also check a conforming binary. Adding a similar check for Windows PE can be done in a separate PR. ACKs for top commit: fanquake: ACK ed1bbcefeaafef460b6e5609de85e13c12e0d2a4 Tree-SHA512: fd437612e003922465fe1396efa1fa3a64bd1c7b0a514d2a0a7a0caaaa9fb5cb43e0ed7caec15eb0a3508692c9eb3212d7ba3c7e8180b942dd3e50616ad6e557
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b8521d6e50..32d1138653 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1698,7 +1698,9 @@ AC_CONFIG_FILES([Makefile src/Makefile doc/man/Makefile share/setup.nsi share/qt
AC_CONFIG_FILES([contrib/devtools/split-debug.sh],[chmod +x contrib/devtools/split-debug.sh])
AM_COND_IF([HAVE_DOXYGEN], [AC_CONFIG_FILES([doc/Doxyfile])])
AC_CONFIG_LINKS([contrib/devtools/security-check.py:contrib/devtools/security-check.py])
+AC_CONFIG_LINKS([contrib/devtools/symbol-check.py:contrib/devtools/symbol-check.py])
AC_CONFIG_LINKS([contrib/devtools/test-security-check.py:contrib/devtools/test-security-check.py])
+AC_CONFIG_LINKS([contrib/devtools/test-symbol-check.py:contrib/devtools/test-symbol-check.py])
AC_CONFIG_LINKS([contrib/filter-lcov.py:contrib/filter-lcov.py])
AC_CONFIG_LINKS([test/functional/test_runner.py:test/functional/test_runner.py])
AC_CONFIG_LINKS([test/fuzz/test_runner.py:test/fuzz/test_runner.py])