aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-04-06 14:43:33 +0800
committerfanquake <fanquake@gmail.com>2021-04-06 14:44:50 +0800
commitc6edcf1c710e4aaf1cafdbf8e86fe209b57bdeb8 (patch)
treea15d88f460f4f1786a2ec9fa94428ad42b68b4d2 /configure.ac
parentb2ec7d398fb03c98f4a758b19fa87d2807af58e3 (diff)
downloadbitcoin-c6edcf1c710e4aaf1cafdbf8e86fe209b57bdeb8.tar.xz
build: suppress libevent warnings if supressing external warnings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c3eabad131..4c8bc4921b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1486,6 +1486,10 @@ if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench
if test x$TARGET_OS != xwindows; then
PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads >= 2.0.21],, [AC_MSG_ERROR([libevent_pthreads version 2.0.21 or greater not found.])])
fi
+
+ if test x$suppress_external_warnings != xno; then
+ EVENT_CFLAGS=SUPPRESS_WARNINGS($EVENT_CFLAGS)
+ fi
fi
dnl QR Code encoding library check