aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2022-09-12 17:33:01 +0000
committerCory Fields <cory-nospam-@coryfields.com>2022-09-12 18:59:48 +0000
commitb50a4b7647c63f2557409308389ef09a67aef5ce (patch)
treea9c81a2c46e06f64a4158a1a9f6c552f7ac52160 /configure.ac
parent5558d2f5496d8fe1c16f9edd1ef395fcd842e6fb (diff)
downloadbitcoin-b50a4b7647c63f2557409308389ef09a67aef5ce.tar.xz
build: quiet warnings in system headers installed from homebrew
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1405adf702..12f8f2dcc6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -746,6 +746,16 @@ case $host in
dnl It's safe to add these paths even if the functionality is disabled by
dnl the user (--without-wallet or --without-gui for example).
+ dnl Homebrew may create symlinks in /usr/local/include for some packages.
+ dnl Because MacOS's clang internally adds "-I /usr/local/include" to its search
+ dnl paths, this will negate efforts to use -isystem for those packages, as they
+ dnl will be found first in /usr/local. Use the internal "-internal-isystem"
+ dnl option to system-ify all /usr/local/include paths without adding it to the list
+ dnl of search paths in case it's not already there.
+ if test "$suppress_external_warnings" != "no"; then
+ AX_CHECK_PREPROC_FLAG([-Xclang -internal-isystem/usr/local/include], [CORE_CPPFLAGS="$CORE_CPPFLAGS -Xclang -internal-isystem/usr/local/include"], [], [$CXXFLAG_WERROR])
+ fi
+
if test "$use_bdb" != "no" && $BREW list --versions berkeley-db@4 >/dev/null && test "$BDB_CFLAGS" = "" && test "$BDB_LIBS" = ""; then
bdb_prefix=$($BREW --prefix berkeley-db@4 2>/dev/null)
dnl This must precede the call to BITCOIN_FIND_BDB48 below.