aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-04-07 15:22:49 +0800
committerfanquake <fanquake@gmail.com>2021-04-07 20:50:10 +0800
commita5491882a06d3bf7c486033037edd9c9203ecaed (patch)
treecb5d9c0dc090af301dd7dea41d3233e0260ce9c1 /configure.ac
parentaa69471ecd553dbcd7dd6d1b2e59dfb69d6a0cf3 (diff)
downloadbitcoin-a5491882a06d3bf7c486033037edd9c9203ecaed.tar.xz
build: fix configuring when building depends with NO_BDB=1
Currently, if you build depends using `NO_BDB=1` (only sqlite wallets), ./configure will fail as it still tries to find bdb. i.e: ```bash checking for Berkeley DB C++ headers... default configure: error: Found Berkeley DB other than 4.8, required for portable BDB wallets (--with-incompatible-bdb to ignore or --without-bdb to disable BDB wallet support) ``` This PR fixes the build such that you can build depends, opting out of bdb without opting out of wallets entirely, and still configure successfully.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cce97e9259..014798d337 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1326,9 +1326,11 @@ fi
if test x$enable_wallet != xno; then
dnl Check for libdb_cxx only if wallet enabled
- BITCOIN_FIND_BDB48
- if test x$suppress_external_warnings != xno ; then
+ if test "x$use_bdb" != "xno"; then
+ BITCOIN_FIND_BDB48
+ if test x$suppress_external_warnings != xno ; then
BDB_CPPFLAGS=SUPPRESS_WARNINGS($BDB_CPPFLAGS)
+ fi
fi
dnl Check for sqlite3