aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Poelstra <apoelstra@wpsoftware.net>2020-12-09 23:35:05 +0000
committerAndrew Poelstra <apoelstra@wpsoftware.net>2020-12-09 23:46:49 +0000
commit904d875cf5aecc337daa6a2243a803033cf4eee3 (patch)
treeeb20ec4584008f55e36134e2bc86e47e3f905a92 /configure.ac
parent0038ce97584f28b0718a4c9f4faa8c0c42c5fe80 (diff)
downloadbitcoin-904d875cf5aecc337daa6a2243a803033cf4eee3.tar.xz
configure: output notice that test binary is disabled by fuzzing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 32d1138653..a956c10908 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1585,7 +1585,11 @@ AM_CONDITIONAL([ENABLE_ZMQ], [test "x$use_zmq" = "xyes"])
AC_MSG_CHECKING([whether to build test_bitcoin])
if test x$use_tests = xyes; then
- AC_MSG_RESULT([yes])
+ if test "x$enable_fuzz" = "xyes"; then
+ AC_MSG_RESULT([no, because fuzzing is enabled])
+ else
+ AC_MSG_RESULT([yes])
+ fi
BUILD_TEST="yes"
else
AC_MSG_RESULT([no])
@@ -1761,8 +1765,10 @@ if test x$bitcoin_enable_qt != xno; then
echo " with qr = $use_qr"
fi
echo " with zmq = $use_zmq"
-echo " with test = $use_tests"
-if test x$use_tests != xno; then
+if test x$enable_fuzz == xno; then
+ echo " with test = $use_tests"
+else
+ echo " with test = not building test_bitcoin because fuzzing is enabled"
echo " with fuzz = $enable_fuzz"
fi
echo " with bench = $use_bench"