aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonas Schnelli <dev@jonasschnelli.ch>2020-12-10 13:18:26 +0100
committerJonas Schnelli <dev@jonasschnelli.ch>2020-12-10 13:18:30 +0100
commit86f20071931b803b5f26ed8f685d98d4919fb7a7 (patch)
tree924daaa7049f4cf95ced7946d782c231ba489532 /configure.ac
parent8e1f9d62731cae288750a3ea5be0b76182f4dd41 (diff)
parentc932e0d67e4b369e4265267da6c8bebac2b6fb53 (diff)
downloadbitcoin-86f20071931b803b5f26ed8f685d98d4919fb7a7.tar.xz
Merge #20527: build: Do not ignore Homebrew's SQLite on macOS
c932e0d67e4b369e4265267da6c8bebac2b6fb53 doc: Update wallet database installation guide for macOS (Hennadii Stepanov) ee7b84e63cbeadd5e680d69ff0548275581e9241 build: Use Homebrew's sqlite package if it is available (Hennadii Stepanov) c96d1f65a552712f8476269ad64a415717ead50d build, refactor: Check that Homebrew's qt5 package is actually installed (Hennadii Stepanov) Pull request description: On master (7ae86b3c6845873ca96650fc69beb4ae5285c801) installed Homebrew `sqlite` package is ignored during build on macOS. This PR fixes this issue and update macOS build docs. Closes #20498. ACKs for top commit: willcl-ark: > > That said, another tACK of [c932e0d](https://github.com/bitcoin/bitcoin/commit/c932e0d67e4b369e4265267da6c8bebac2b6fb53) hebasto: > That said, another tACK of [c932e0d](https://github.com/bitcoin/bitcoin/commit/c932e0d67e4b369e4265267da6c8bebac2b6fb53) laanwj: Code review ACK c932e0d67e4b369e4265267da6c8bebac2b6fb53 jonasschnelli: code review re-ACK c932e0d67e4b369e4265267da6c8bebac2b6fb53 Tree-SHA512: 2563f25534d065556b17ee8c0fca957aea61b5ae288a2aa72743e77607843a45c39f209321e0f05b34283a74d2edcf961cf1dc54a35ed0cc21182304bb961505
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0f86f41200..9d951afba1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -645,16 +645,19 @@ case $host in
dnl It's safe to add these paths even if the functionality is disabled by
dnl the user (--without-wallet or --without-gui for example).
- qt5_prefix=$($BREW --prefix qt5 2>/dev/null)
- if $BREW list --versions berkeley-db4 >/dev/null && test "x$BDB_CFLAGS" = "x" && test "x$BDB_LIBS" = "x" && test "$use_bdb" != "no"; then
+ if test "x$use_bdb" != xno && $BREW list --versions berkeley-db4 >/dev/null && test "x$BDB_CFLAGS" = "x" && test "x$BDB_LIBS" = "x"; then
bdb_prefix=$($BREW --prefix berkeley-db4 2>/dev/null)
dnl This must precede the call to BITCOIN_FIND_BDB48 below.
BDB_CFLAGS="-I$bdb_prefix/include"
BDB_LIBS="-L$bdb_prefix/lib -ldb_cxx-4.8"
fi
- if test x$qt5_prefix != x; then
- PKG_CONFIG_PATH="$qt5_prefix/lib/pkgconfig:$PKG_CONFIG_PATH"
- export PKG_CONFIG_PATH
+
+ if test "x$use_sqlite" != xno && $BREW list --versions sqlite3 >/dev/null; then
+ export PKG_CONFIG_PATH="$($BREW --prefix sqlite3 2>/dev/null)/lib/pkgconfig:$PKG_CONFIG_PATH"
+ fi
+
+ if $BREW list --versions qt5 >/dev/null; then
+ export PKG_CONFIG_PATH="$($BREW --prefix qt5 2>/dev/null)/lib/pkgconfig:$PKG_CONFIG_PATH"
fi
fi
else