aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonas Schnelli <dev@jonasschnelli.ch>2020-12-07 22:16:06 +0100
committerJonas Schnelli <dev@jonasschnelli.ch>2020-12-07 22:16:39 +0100
commit836a3dc02c72f917db5be386b9b4787a59d48610 (patch)
tree94ddb2a624566c612baf852a45d20af04c0e7893 /configure.ac
parent41a413b31746cc749f3c64ed8070cea9cc6cfdbe (diff)
downloadbitcoin-836a3dc02c72f917db5be386b9b4787a59d48610.tar.xz
Avoid weak-linked getauxval support on non-linux platforms (like macOS)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 682e0e8c6e..723e290cc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1116,8 +1116,10 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_CHECKING(for weak getauxval support in the compiler)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #ifdef __linux__
unsigned long getauxval(unsigned long type) __attribute__((weak));
#define AT_HWCAP 16
+ #endif
]], [[
getauxval(AT_HWCAP);
]])],