aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-02-15 15:53:02 +0800
committerfanquake <fanquake@gmail.com>2021-02-17 08:04:11 +0800
commit7bf04e358a6550ac9851f1b2d87795927fc5ff4b (patch)
tree534789b5b5795fc4fd456746fb04d5635869a6a7 /configure.ac
parent92fee79dab384acea47bf20741a9847a58253330 (diff)
downloadbitcoin-7bf04e358a6550ac9851f1b2d87795927fc5ff4b.tar.xz
build: remove mostly pointless BOOST_PROCESS macro
Performing a series of link checks for a Boost component that is header-only doesn't make much sense, and currently means we just have another confusing Boost macro in our tree. I'm not sure why this was originally done this way; maybe Sjors or luke-jr can elaborate (#15382 (929cda5470f98d1ef85c05b1cad4e2fb9227e3b0))? The macro also has the side-effect of producing confusing error messages. i.e in #20744, the CI is currently failing with: ```bash checking for boostlib >= 1.58.0 (105800) lib path in "/tmp/cirrus-ci-build/depends/x86_64-pc-linux-gnu/lib"... yes checking for boostlib >= 1.58.0 (105800)... yes checking whether the Boost::Process library is available... yes configure: error: Could not find a version of the Boost::Process library! ``` This isn't useful, given there is no such thing as a `Boost::Process` library. This PR just removes the macro entirely, but maintains a `--with-boost-process` (defaulting to off), flag to configure. Hopefully this will also be removed, in favour of `--enable-disable-external-signer` if/when #16546 is merged.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 15 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 62f1c308b7..0b2721673f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -338,6 +338,11 @@ AC_ARG_ENABLE([werror],
[enable_werror=$enableval],
[enable_werror=no])
+AC_ARG_WITH([boost-process],
+ [AS_HELP_STRING([--with-boost-process],[Opt in to using Boost Process (default is no)])],
+ [boost_process=$withval],
+ [boost_process=no])
+
AC_LANG_PUSH([C++])
dnl Check for a flag to turn compiler warnings into errors. This is helpful for checks which may
@@ -1388,8 +1393,15 @@ fi
AX_BOOST_SYSTEM
AX_BOOST_FILESYSTEM
-dnl Opt-in to boost-process
-AS_IF([ test x$with_boost_process != x ], [ AX_BOOST_PROCESS ], [ ax_cv_boost_process=no ] )
+dnl Opt-in to Boost Process
+if test "x$boost_process" != xno; then
+AC_MSG_CHECKING(for Boost Process)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <boost/process.hpp>]],
+ [[ boost::process::child* child = new boost::process::child; delete child; ]])],
+ [ AC_MSG_RESULT(yes); AC_DEFINE([HAVE_BOOST_PROCESS],,[define if Boost::Process is available])],
+ [ AC_MSG_ERROR([Boost::Process is not available!])]
+)
+fi
if test x$suppress_external_warnings != xno; then
BOOST_CPPFLAGS=SUPPRESS_WARNINGS($BOOST_CPPFLAGS)
@@ -1876,7 +1888,7 @@ esac
echo
echo "Options used to compile and link:"
-echo " boost process = $ax_cv_boost_process"
+echo " boost process = $with_boost_process"
echo " multiprocess = $build_multiprocess"
echo " with libs = $build_bitcoin_libs"
echo " with wallet = $enable_wallet"