aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-06-10 11:14:49 +0100
committerfanquake <fanquake@gmail.com>2022-06-10 12:39:08 +0100
commit491bb14c0c9cf040154d57e246206ffb2f86a7e5 (patch)
tree196a12d1159b9d54c525e5eb223f22aec4191202 /configure.ac
parente3c08eb620a2f317fc09fdf20969fa26f02afb91 (diff)
downloadbitcoin-491bb14c0c9cf040154d57e246206ffb2f86a7e5.tar.xz
build: test for timingsafe_bcmp
Code introduced in #15649 added usage of `timingsafe_bcmp()`, if available, otherwise falling back to our own implementation. However the relevant build system check was never added, so currently, we'll always just use our implementation, as HAVE_TIMINGSAFE_BCMP will never be defined. Add the check for timingsafe_bcmp. Note that as far as I'm aware, it's only available on OpenBSD.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f6d00d0283..003d76989b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -998,6 +998,8 @@ AC_CHECK_DECLS([setsid])
AC_CHECK_DECLS([pipe2])
+AC_CHECK_FUNCS([timingsafe_bcmp])
+
AC_CHECK_DECLS([le16toh, le32toh, le64toh, htole16, htole32, htole64, be16toh, be32toh, be64toh, htobe16, htobe32, htobe64],,,
[#if HAVE_ENDIAN_H
#include <endian.h>