aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonas Schnelli <dev@jonasschnelli.ch>2020-12-07 21:22:01 +0100
committerJonas Schnelli <dev@jonasschnelli.ch>2020-12-07 21:22:01 +0100
commit41a413b31746cc749f3c64ed8070cea9cc6cfdbe (patch)
tree6d731dd048169efeef66f68a1b610f7bfe5b31d4 /configure.ac
parentd38feb6134e2aaeeb9991cc25f7e94fa8451795b (diff)
downloadbitcoin-41a413b31746cc749f3c64ed8070cea9cc6cfdbe.tar.xz
Define correct symbols for getauxval
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 32d1138653..682e0e8c6e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1110,7 +1110,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
]], [[
getauxval(AT_HWCAP);
]])],
- [ AC_MSG_RESULT(yes); HAVE_STRONG_GETAUXVAL=1 ],
+ [ AC_MSG_RESULT(yes); HAVE_STRONG_GETAUXVAL=1; AC_DEFINE(HAVE_STRONG_GETAUXVAL, 1, [Define this symbol to build code that uses getauxval)]) ],
[ AC_MSG_RESULT(no); HAVE_STRONG_GETAUXVAL=0 ]
)
@@ -1121,7 +1121,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
]], [[
getauxval(AT_HWCAP);
]])],
- [ AC_MSG_RESULT(yes); HAVE_WEAK_GETAUXVAL=1 ],
+ [ AC_MSG_RESULT(yes); HAVE_WEAK_GETAUXVAL=1; AC_DEFINE(HAVE_WEAK_GETAUXVAL, 1, [Define this symbol to build code that uses getauxval (weak linking)]) ],
[ AC_MSG_RESULT(no); HAVE_WEAK_GETAUXVAL=0 ]
)