aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKiminuo <kiminuo@protonmail.com>2020-06-11 10:04:33 +0200
committerfanquake <fanquake@gmail.com>2022-02-03 18:35:52 +0800
commitb87f9c5edf3895df9650131fcf8551c3ad1d7301 (patch)
tree49452ef57938298ccc5f321cd2e7788b295b8b65 /configure.ac
parent41d7166c8a598b604aad6c6b1d88ad46e23be247 (diff)
downloadbitcoin-b87f9c5edf3895df9650131fcf8551c3ad1d7301.tar.xz
build: remove boost::filesystem usage
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5db104f0d6..adefbbc2f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1408,13 +1408,12 @@ if test "$use_boost" = "yes"; then
AC_MSG_ERROR([only libbitcoinconsensus can be built without Boost])
fi
AX_BOOST_SYSTEM
- AX_BOOST_FILESYSTEM
if test "$suppress_external_warnings" != "no"; then
BOOST_CPPFLAGS=SUPPRESS_WARNINGS($BOOST_CPPFLAGS)
fi
- BOOST_LIBS="$BOOST_LDFLAGS $BOOST_SYSTEM_LIB $BOOST_FILESYSTEM_LIB"
+ BOOST_LIBS="$BOOST_LDFLAGS $BOOST_SYSTEM_LIB"
fi
if test "$use_external_signer" != "no"; then