aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-03-23 15:01:46 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-03-26 09:04:19 +0100
commitaaf72d62c18f9cb325c150cf0cc21abb201607c8 (patch)
tree6cf0342b2d6b065f781fba126ee99191c96d0b83 /configure.ac
parent2f0f056e08cd5a1435120592a9ecd212fcdb915b (diff)
downloadbitcoin-aaf72d62c18f9cb325c150cf0cc21abb201607c8.tar.xz
build: Bump libevent minimum version up to 2.1.8
Required to support new functionality.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 298b72a381..5f08ee7355 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1526,9 +1526,9 @@ fi
dnl libevent check
if test "$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests$use_bench" != "nonononono"; then
- PKG_CHECK_MODULES([EVENT], [libevent >= 2.0.21], [use_libevent=yes], [AC_MSG_ERROR([libevent version 2.0.21 or greater not found.])])
+ PKG_CHECK_MODULES([EVENT], [libevent >= 2.1.8], [use_libevent=yes], [AC_MSG_ERROR([libevent version 2.1.8 or greater not found.])])
if test "$TARGET_OS" != "windows"; then
- PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads >= 2.0.21],, [AC_MSG_ERROR([libevent_pthreads version 2.0.21 or greater not found.])])
+ PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads >= 2.1.8], [], [AC_MSG_ERROR([libevent_pthreads version 2.1.8 or greater not found.])])
fi
if test "$suppress_external_warnings" != "no"; then