aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorS3RK <1466284+S3RK@users.noreply.github.com>2021-07-06 08:57:23 +0200
committerS3RK <1466284+S3RK@users.noreply.github.com>2021-07-06 08:57:23 +0200
commita8b515c317f0b5560f62c72a8f4eb6560d8f1c75 (patch)
treedf30bbecbfe3c1b2865801f8925ad9266f5aeb21 /configure.ac
parent3f56ef7bef22f0c8c94ad7e401d50b188dae2cbe (diff)
configure: keep relative paths in debug info
Revert to the state prior to e507acbe and allow debugging from project root dir with `gdb src/bitcoind`.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 88f91004af..20ba0f72d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1627,8 +1627,8 @@ if test "x$use_ccache" != "xno"; then
fi
AC_MSG_RESULT($use_ccache)
if test "x$use_ccache" = "xyes"; then
- AX_CHECK_COMPILE_FLAG([-fdebug-prefix-map=A=B],[DEBUG_CXXFLAGS="$DEBUG_CXXFLAGS -fdebug-prefix-map=\$(abs_srcdir)=."],,[[$CXXFLAG_WERROR]])
- AX_CHECK_PREPROC_FLAG([-fmacro-prefix-map=A=B],[DEBUG_CPPFLAGS="$DEBUG_CPPFLAGS -fmacro-prefix-map=\$(abs_srcdir)=."],,[[$CXXFLAG_WERROR]])
+ AX_CHECK_COMPILE_FLAG([-fdebug-prefix-map=A=B],[DEBUG_CXXFLAGS="$DEBUG_CXXFLAGS -fdebug-prefix-map=\$(abs_top_srcdir)=."],,[[$CXXFLAG_WERROR]])
+ AX_CHECK_PREPROC_FLAG([-fmacro-prefix-map=A=B],[DEBUG_CPPFLAGS="$DEBUG_CPPFLAGS -fmacro-prefix-map=\$(abs_top_srcdir)=."],,[[$CXXFLAG_WERROR]])
fi
fi