aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-03-10 12:35:39 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-03-10 13:07:42 +0100
commit1d4157a42b77411579eb721b5c6fb533a357959d (patch)
tree5e3559b2175b301a36c643c1028e2e7e5939ecb5 /configure.ac
parent05957a888de98aa4b946b62747030d6c77cac488 (diff)
downloadbitcoin-1d4157a42b77411579eb721b5c6fb533a357959d.tar.xz
build: Fix Boost.Process detection on macOS arm64
Could be tested as follows: ``` % brew install boost@1.76 % ./autogen.sh % ./configure --with-boost='/opt/homebrew/opt/boost@1.76' ```
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 06a208835b..63ff6a1ebd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1446,6 +1446,8 @@ if test "$use_external_signer" != "no"; then
;;
*)
AC_MSG_CHECKING([whether Boost.Process can be used])
+ TEMP_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $BOOST_CPPFLAGS"
TEMP_LDFLAGS="$LDFLAGS"
dnl Boost 1.73 and older require the following workaround.
LDFLAGS="$LDFLAGS $PTHREAD_CFLAGS"
@@ -1453,6 +1455,7 @@ if test "$use_external_signer" != "no"; then
[have_boost_process="yes"],
[have_boost_process="no"])
LDFLAGS="$TEMP_LDFLAGS"
+ CPPFLAGS="$TEMP_CPPFLAGS"
AC_MSG_RESULT([$have_boost_process])
if test "$have_boost_process" = "yes"; then
use_external_signer="yes"