aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-12-03 23:39:14 +0200
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2020-12-03 23:39:14 +0200
commitd3ef947524a07f8d7fbad5b95781ab6cacb1cb49 (patch)
tree8039642ab80a8f41475ed3547db5fd987e05f219 /configure.ac
parenta0489f3472f3799dc1ece32a59556fd239c4c14b (diff)
downloadbitcoin-d3ef947524a07f8d7fbad5b95781ab6cacb1cb49.tar.xz
build: Check that Homebrew's berkeley-db4 package is actually installed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e89d86df8b..5a538a1de3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -641,9 +641,9 @@ case $host in
dnl It's safe to add these paths even if the functionality is disabled by
dnl the user (--without-wallet or --without-gui for example).
- bdb_prefix=$($BREW --prefix berkeley-db4 2>/dev/null)
qt5_prefix=$($BREW --prefix qt5 2>/dev/null)
- if test x$bdb_prefix != x && test "x$BDB_CFLAGS" = "x" && test "x$BDB_LIBS" = "x" && test "$use_bdb" != "no"; then
+ if $BREW list --versions berkeley-db4 >/dev/null && test "x$BDB_CFLAGS" = "x" && test "x$BDB_LIBS" = "x" && test "$use_bdb" != "no"; then
+ bdb_prefix=$($BREW --prefix berkeley-db4 2>/dev/null)
dnl This must precede the call to BITCOIN_FIND_BDB48 below.
BDB_CFLAGS="-I$bdb_prefix/include"
BDB_LIBS="-L$bdb_prefix/lib -ldb_cxx-4.8"