aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2021-11-22 11:54:09 +0100
committerMarcoFalke <falke.marco@gmail.com>2021-11-22 11:54:16 +0100
commitee7e06156357c333caef381b6acb3109d0187666 (patch)
tree8afa68fe98175f01a19e71c9d0994f5c88dd4491 /configure.ac
parent3a36ec83d024a1343bee8e390833eb1fd7a3705d (diff)
parentcf7292597e18ffca06b0fbf8bcd545aec387e380 (diff)
downloadbitcoin-ee7e06156357c333caef381b6acb3109d0187666.tar.xz
Merge bitcoin/bitcoin#23557: configure.ac: remove Bashism
cf7292597e18ffca06b0fbf8bcd545aec387e380 configure.ac: remove Bashism (Matt Whitlock) Pull request description: Configure scripts are supposed to adhere to the POSIX shell language. The POSIX `test` builtin does not implement an `==` operator. Bash does, but not all systems have Bash installed as `/bin/sh`. In particular, many systems use the lighter-weight Dash as the default POSIX shell. Dash emits the following error when running `configure`: ``` ./configure: 39065: test: xno: unexpected operator ``` This PR removes the Bashism and restores correct operation with POSIX-compliant shells like Dash. ACKs for top commit: katesalazar: ACK cf7292597e18ffca06b0fbf8bcd545aec387e380. laanwj: Code review ACK cf7292597e18ffca06b0fbf8bcd545aec387e380 Tree-SHA512: 578c873fba52e0472baed9e024bddcf58a0e088600bd5854f3011f1f8d135773ad923bb16baefc960d17ecedee9cc980b36aaa70fb32eb9bc7de93f7fe60541d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8047c4188a..507dc9399f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1923,7 +1923,7 @@ if test x$bitcoin_enable_qt != xno; then
echo " with qr = $use_qr"
fi
echo " with zmq = $use_zmq"
-if test x$enable_fuzz == xno; then
+if test x$enable_fuzz = xno; then
echo " with test = $use_tests"
else
echo " with test = not building test_bitcoin because fuzzing is enabled"