aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-10-20 16:13:23 +0800
committerfanquake <fanquake@gmail.com>2021-10-20 16:16:34 +0800
commitd7524546abf1fa5be8e6317ee50585e966ae6b4c (patch)
treefe3fd8830321aff233bf750f552c390410c20e0d /configure.ac
parentf9ad4d51e3dbb84036762f5a9e0c6d712e49d1be (diff)
downloadbitcoin-d7524546abf1fa5be8e6317ee50585e966ae6b4c.tar.xz
build: explicitly disable libsecp256k1 openssl based tests
These tests are failing when run against OpenSSL 3, and have been removed upstream, https://github.com/bitcoin-core/secp256k1/pull/983, so disabled them for now to avoid `make check` failures. Note that this will also remove warning output from our build, due to the use of deprecated OpenSSL API functions. See #23048.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5d21c50744..ae8ee783eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1878,7 +1878,7 @@ PKGCONFIG_LIBDIR_TEMP="$PKG_CONFIG_LIBDIR"
unset PKG_CONFIG_LIBDIR
PKG_CONFIG_LIBDIR="$PKGCONFIG_LIBDIR_TEMP"
-ac_configure_args="${ac_configure_args} --disable-shared --with-pic --enable-benchmark=no --enable-module-recovery --enable-module-schnorrsig --enable-experimental"
+ac_configure_args="${ac_configure_args} --disable-shared --with-pic --enable-benchmark=no --enable-module-recovery --enable-module-schnorrsig --enable-experimental --disable-openssl-tests"
AC_CONFIG_SUBDIRS([src/secp256k1])
AC_OUTPUT