aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-06-20 14:04:37 +0200
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-06-20 14:04:37 +0200
commitb5f6a4650334d58245b45eace57f2bc23467ffc7 (patch)
tree47f781599fafb2aa89da232df41889c855811758 /configure.ac
parenta09033e22c4f072c86a1885dd476f3059e5416d1 (diff)
downloadbitcoin-b5f6a4650334d58245b45eace57f2bc23467ffc7.tar.xz
build: Fix `::_wsystem` check
See https://docs.microsoft.com/en-us/cpp/c-runtime-library/reference/system-wsystem
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a4a23474c8..ffa445b46f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1261,8 +1261,8 @@ AC_LINK_IFELSE(
AC_MSG_CHECKING([for ::_wsystem])
AC_LINK_IFELSE(
[ AC_LANG_PROGRAM(
- [[ ]],
- [[ int nErr = ::_wsystem(""); ]]
+ [[ #include <stdlib.h> ]],
+ [[ int nErr = ::_wsystem(NULL); ]]
)],
[ AC_MSG_RESULT([yes]); have_any_system=yes],
[ AC_MSG_RESULT([no]) ]