aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-03-27 14:56:44 +0800
committerfanquake <fanquake@gmail.com>2020-04-06 14:08:56 +0800
commita029805f57fa9a4ab9867c0d1e865675d57537c7 (patch)
tree2356e2c9d6ca81a810c9cff8f44618c9b14a69c4 /configure.ac
parent516ebe8a62de1906f8be9c4a144ea5753678eb4f (diff)
downloadbitcoin-a029805f57fa9a4ab9867c0d1e865675d57537c7.tar.xz
build: remove -Qunused-arguments workaround for clang + ccache
This was added in 386efb7695debaf5f0f328a2e4c9abc342161665 to address spammy Clang warnings when building with ccache. The issue was addressed in ccache 3.2 (https://bugzilla.samba.org/show_bug.cgi?id=8118, Nov 2014), and from a look at all major distros, it's only Debian Jessie that has a version of ccache older than that (3.1). Therefore I think it's acceptable to drop this workaround, and re-enable warnings for unused driver arguments (when compiling using Clang).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a2d33ff5b6..2cb3a2dda5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1410,9 +1410,6 @@ if test "x$use_ccache" != "xno"; then
fi
AC_MSG_RESULT($use_ccache)
fi
-if test "x$use_ccache" = "xyes"; then
- AX_CHECK_PREPROC_FLAG([-Qunused-arguments],[CPPFLAGS="-Qunused-arguments $CPPFLAGS"])
-fi
dnl enable wallet
AC_MSG_CHECKING([if wallet should be enabled])