aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorlaanwj <126646+laanwj@users.noreply.github.com>2022-01-13 11:20:27 +0100
committerlaanwj <126646+laanwj@users.noreply.github.com>2022-01-13 11:23:39 +0100
commit31db3dd874dfbba88616c96a5767e2c9861d9a7a (patch)
tree0da3836628e4af8b8e525ee780e7b267d90815f8 /configure.ac
parent290ff5ef6d3886409e5e8688f7d28a4c8246c617 (diff)
parent18f304d988117f2675e7393adda9f960fbf3cb3a (diff)
downloadbitcoin-31db3dd874dfbba88616c96a5767e2c9861d9a7a.tar.xz
Merge bitcoin/bitcoin#24048: build: Improve error message when pkg-config is not installed
18f304d988117f2675e7393adda9f960fbf3cb3a build: Improve error message when pkg-config is not installed (Hennadii Stepanov) Pull request description: Fixes bitcoin/bitcoin#24037. With this PR: ``` # ./autogen.sh configure.ac:16: error: PKG_PROG_PKG_CONFIG macro not found. Please install pkg-config and re-run autogen.sh configure.ac:16: the top level autom4te: /usr/bin/m4 failed with exit status: 1 aclocal: error: /usr/bin/autom4te failed with exit status: 1 autoreconf: aclocal failed with exit status: 1 ``` ACKs for top commit: laanwj: Tested ACK 18f304d988117f2675e7393adda9f960fbf3cb3a jarolrod: ACK 18f304d988117f2675e7393adda9f960fbf3cb3a Tree-SHA512: ba845f44c966fea6cf7cee0db9cacc431072e2005ad065c8f2bbe3cffd8415c3af6ed443cccf9606df7de4df2ff3e72636afb5f3776d2a96af8572aab7018549
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9b080eb0c8..042147f782 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,7 +13,7 @@ AC_CONFIG_HEADERS([src/config/bitcoin-config.h])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_MACRO_DIR([build-aux/m4])
-m4_ifndef([PKG_PROG_PKG_CONFIG], [AC_MSG_ERROR([PKG_PROG_PKG_CONFIG macro not found. Please install pkg-config and re-run autogen.sh])])
+m4_ifndef([PKG_PROG_PKG_CONFIG], [m4_fatal([PKG_PROG_PKG_CONFIG macro not found. Please install pkg-config and re-run autogen.sh])])
PKG_PROG_PKG_CONFIG
if test "$PKG_CONFIG" = ""; then
AC_MSG_ERROR([pkg-config not found])