aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-04-19 20:20:06 +0800
committerfanquake <fanquake@gmail.com>2020-04-20 16:58:54 +0800
commit20a30922fbf6ba14e250ca649239af115dbbe7b0 (patch)
tree1aa995a75d748ea4b480a8e4c8ff481040eabde5 /configure.ac
parentd65631171cf87a1b25d50317a9e27338a4dc0d8b (diff)
downloadbitcoin-20a30922fbf6ba14e250ca649239af115dbbe7b0.tar.xz
doc: note why we can't use thread_local with glibc back compat
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4c9902efc6..77cd23c0b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -861,6 +861,9 @@ AC_LINK_IFELSE([AC_LANG_SOURCE([
]
)
+dnl thread_local is currently disabled when building with glibc back compat.
+dnl Our minimum supported glibc is 2.17, however support for thread_local
+dnl did not arrive in glibc until 2.18.
if test "x$use_thread_local" = xyes || { test "x$use_thread_local" = xauto && test "x$use_glibc_compat" = xno; }; then
TEMP_LDFLAGS="$LDFLAGS"
LDFLAGS="$TEMP_LDFLAGS $PTHREAD_CFLAGS"