aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-05-30 11:35:41 +0100
committerfanquake <fanquake@gmail.com>2022-05-31 06:41:16 +0100
commita7973bf8f46a7fe1c70d33a1098da6aba66baaed (patch)
tree0c6719154c4b6d9966639e604fd92e5efb30f49b /configure.ac
parentb9ef5a10e2fa4609d048db57b99463305455ebe4 (diff)
downloadbitcoin-a7973bf8f46a7fe1c70d33a1098da6aba66baaed.tar.xz
Revert "build: more robustly check for fcf-protection support"
We no-longer support Clang 7 (#24164). This reverts commit e9189a750b237eba1befc6b16c12c2cee3e0176c.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 357e818b3d..e09ef14156 100644
--- a/configure.ac
+++ b/configure.ac
@@ -935,10 +935,7 @@ if test "$use_hardening" != "no"; then
AX_CHECK_COMPILE_FLAG([-Wstack-protector], [HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -Wstack-protector"])
AX_CHECK_COMPILE_FLAG([-fstack-protector-all], [HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fstack-protector-all"])
- dnl -fcf-protection used with Clang 7 causes ld to emit warnings:
- dnl ld: error: ... <corrupt x86 feature size: 0x8>
- dnl Use CHECK_LINK_FLAG & --fatal-warnings to ensure we won't use the flag in this case.
- AX_CHECK_LINK_FLAG([-fcf-protection=full], [HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fcf-protection=full"], [], [$LDFLAG_WERROR])
+ AX_CHECK_COMPILE_FLAG([-fcf-protection=full], [HARDENED_CXXFLAGS="$HARDENED_CXXFLAGS -fcf-protection=full"])
case $host in
*mingw*)